StarCraft II’s System Requirements Revealed

System Requirements For StarCraft II’s Beta Reveal The Game Will Work For Just About Everyone

January 29, 2010 – Today Blizzard revealed the system requirements for the StarCraft II beta. The system requirements are minimal so that gamers running everything from the latest Alienware PC to an eight-year old Dell will have the opportunity to play the RTS game.

StarCraft II: Wings of Liberty is the sequel to the highly-acclaimed, incredibly revered RTS title that Blizzard introduced to gamers in 1998. StarCraft II will take place four years after the events of the “Brood War” expansion pack. Players will be able to assume control over the Terrans, the Zerg and the Protoss.

Below are the system requirements (required & recommended). Can your PC support it? I bet it can!

Keep in mind that the Beta will also require a valid e-mail address and a broadband connection in order to play online via Battle.net.


Required

Processor: Intel Pentium IV 1.3GHz, AMD XP 1500+

Operating System: Windows XP / XP64 (Service Pack 3), Windows Vista / Vista64 (service Pack 1), Windows 7 Home Premium

Memory: (Windows XP) 512mb, (Windows Vista) 1024mb, (Windows 7) 1024mb

Video Card: 3D graphics processor with Hardware Transform and Lighting with 32 MB VRAM such as an ATI Radeon 7200 or NVIDIA GeForce 2 class card or better

Hard Drive Space: 15GB

DirectX: DirectX9.0c

Recommended

Processor: Intel Pentium D, AMD 64 X2

Operating System: Windows XP / XP64 (Service Pack 3), Windows Vista / Vista64 (service Pack 1), Windows 7 Home Premium

Memory: (Windows XP) 1024mb, (Windows Vista) 2048mb, (Windows 7) 2048mb

Video Card: 3D graphics processor with Vertex and Pixel Shader capability with 128 MB VRAM such as an ATI Radeon X1600 or NVIDIA GeForce 7600 GT class card or better

Hard Drive Space: 15GB

DirectX: DirectX9.0c


Update

Blizzard just informed our friends over at Kotaku that the system requirements have been taken down from their site because they are NOT the requirements for StarCraft II. Sigh. We know. We’re upset, too. It seems that someone invaded their site and posted the requirements for World of Warcraft.